Author Topic: bigace 3 installation.  (Read 14387 times)

0 Members and 1 Guest are viewing this topic.

remedy

  • Advanced User
  • ***
  • Posts: 54
bigace 3 installation.
« on: August 10, 2010, 08:19:43 PM »
the install .php was perfect in that it installed everything it seems.

when I try to go to the bigace installed site (default no modifiecations) I get the following error in my error_log file

[Tue Aug 10 14:13:05 2010] [error] [client 192.168.0.1] PHP Fatal error:  Class 'DOMDocument' not found in /home/bigace3/public_html/library/Bigace/Widget/DefaultService.php on line 105

Kevin

  • Global Moderator
  • Bigace Guru
  • *****
  • Posts: 3139
    • Kevin Papst
Re: bigace 3 installation.
« Reply #1 on: August 10, 2010, 11:42:39 PM »
Ok, which means the installer does not check all dependencies.
DOMDocument is a class from the XML package - not sure which library though ... which is a commonly used extension.
Did the installer not give you a warning?

I will add a Pre-Install check - you could check which PHP version you are using. Local installation? Then try to install something like php5-xml .

remedy

  • Advanced User
  • ***
  • Posts: 54
Re: bigace 3 installation.
« Reply #2 on: August 11, 2010, 02:08:18 AM »
the pre-install check was all green when I installed.
I had to add image-magic and the php-gd library
can you tell me what library I need to add?

remedy

  • Advanced User
  • ***
  • Posts: 54
Re: bigace 3 installation.
« Reply #3 on: August 11, 2010, 02:19:31 AM »
I installed all php modules I could find.

now my error is ...
[Tue Aug 10 20:17:38 2010] [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations
[Tue Aug 10 20:17:44 2010] [error] [client 192.168.0.1] PHP Fatal error:  Call to undefined method Zend_View_Helper_Placeholder_Container::ksort() in /home/bigace3/public_html/library/Zend/View/Helper/HeadStyle.php on line 385
[Tue Aug 10 20:18:00 2010] [error] [client 192.168.0.1] PHP Fatal error:  Call to undefined method Zend_View_Helper_Placeholder_Container::ksort() in /home/bigace3/public_html/library/Zend/View/Helper/HeadStyle.php on line 385

remedy

  • Advanced User
  • ***
  • Posts: 54
Re: bigace 3 installation.
« Reply #4 on: August 11, 2010, 02:25:36 AM »
FYI my link was going to the public folder right after you type in the main host name
/public/

remedy

  • Advanced User
  • ***
  • Posts: 54
Re: bigace 3 installation.
« Reply #5 on: August 11, 2010, 05:05:40 AM »
PHP 5.1.6 (cli) (built: Mar 31 2010 02:44:37)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

Kevin

  • Global Moderator
  • Bigace Guru
  • *****
  • Posts: 3139
    • Kevin Papst
Re: bigace 3 installation.
« Reply #6 on: August 11, 2010, 09:22:40 AM »
What could be the reason for the troubles, Zend themself require 5.2.4 or later:
http://zendframework.com/manual/en/requirements.introduction.html

You can read about the problem here:
http://framework.zend.com/issues/browse/ZF-5883

A possible solution can be found here:
http://zend-framework-community.634137.n4.nabble.com/Exception-with-HeadLink-td670321.html

I will update the installation pre-check to take care about that requirement as well.

whaba

  • Newbie
  • *
  • Posts: 1
Re: bigace 3 installation.
« Reply #7 on: April 26, 2012, 12:01:33 AM »
Hi, I also got a problem after installing bigace 3
I looked good - no messages by installing, but when i wanted to go the website i got this message:

An error occurred
BIGACE: 500

Error: 0 - Configured module "displayContent" is not existing: "C:\xampp\htdocs\bigace_3.0/sites/cid1/modules/displayContent/modul.phtml"

As you see i installed it on a local server for testing!

version 2.7.7 is working good!